File pykolab.spec of Package pykolab (Revision 7d9c904b735aa8230580c586b5e31cde)

Currently displaying revision 7d9c904b735aa8230580c586b5e31cde , Show latest

764
 
1
%if 0%{?opensuse_bs}
2
#!BuildIgnore:  systemd
3
%endif
4
5
%{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6
7
%if 0%{?suse_version} || 0%{?fedora} > 17 || 0%{?rhel} > 6
8
%global with_systemd 1
9
%{!?_unitdir:   %global _unitdir /usr/lib/systemd/system/}
10
%{!?_rundir:    %global _rundir  %{_localstatedir}/run}
11
%else
12
%global with_systemd 0
13
%endif
14
15
%global kolab_user kolab
16
%global kolab_user_id 412
17
%global kolab_group kolab
18
%global kolab_group_id 412
19
20
%global kolabn_user kolab-n
21
%global kolabn_user_id 413
22
%global kolabn_group kolab-n
23
%global kolabn_group_id 413
24
25
%global kolabr_user kolab-r
26
%global kolabr_user_id 414
27
%global kolabr_group kolab-r
28
%global kolabr_group_id 414
29
30
Summary:            Kolab Groupware Solution
31
Name:               pykolab
32
Version:            0.8.7
33
Release:            1%{?dist}
34
License:            GPLv3+
35
Group:              Applications/System
36
URL:                http://kolab.org/
37
38
Source0:            pykolab-%{version}.tar.gz
39
Source1:            pykolab.logrotate
40
41
Patch0001:          pykolab-0.8-patch-out-manticore.patch
42
43
BuildRoot:          %{_tmppath}/%{name}-%{version}-%{release}-root
44
BuildArch:          noarch
45
46
%if 0%{?suse_version}
47
BuildRequires:      autoconf
48
BuildRequires:      automake
49
BuildRequires:      fdupes
50
%endif
51
52
%if 0%{?fedora} > 21
53
BuildRequires:      future
54
%endif
55
56
BuildRequires:      gcc
57
BuildRequires:      gettext
58
BuildRequires:      glib2-devel
59
BuildRequires:      intltool
60
61
%if 0%{?suse_version}
62
BuildRequires:      python-mysql
63
%else
64
BuildRequires:      MySQL-python
65
%endif
66
67
BuildRequires:      python
68
BuildRequires:      python-augeas
69
BuildRequires:      python-gnupg
70
BuildRequires:      python-icalendar
71
BuildRequires:      python-kolab
72
BuildRequires:      python-kolabformat
73
BuildRequires:      python-ldap
74
BuildRequires:      python-nose
75
BuildRequires:      python-pep8
76
BuildRequires:      python-pyasn1
77
BuildRequires:      python-pyasn1-modules
78
79
%if 0%{?suse_version}
80
BuildRequires:      python-pytz
81
%else
82
BuildRequires:      pytz
83
%endif
84
85
BuildRequires:      python-sievelib
86
BuildRequires:      python-sqlalchemy
87
88
%if 0%{?fedora} >= 23
89
# Fedora 23 has python2-twisted and python-twisted
90
BuildRequires:      python-twisted
91
%else
92
BuildRequires:      python-twisted-core
93
%endif
94
BuildRequires:      python-tzlocal
95
96
%if 0%{?fedora} >= 21
97
# Fedora 21 has qca2 and qca, qca2 has been renamed to qca, required by kdelibs
98
BuildRequires:      qca
99
%endif
100
101
Requires:           kolab-cli = %{version}-%{release}
102
Requires:           python-ldap >= 2.4
103
Requires:           python-pyasn1
104
Requires:           python-pyasn1-modules
105
Requires(pre):      /usr/sbin/useradd
106
Requires(pre):      /usr/sbin/usermod
107
Requires(pre):      /usr/sbin/groupadd
108
109
%if 0%{?with_systemd}
110
%if 0%{?suse_version}
111
Requires(post):     systemd
112
Requires(postun):   systemd
113
Requires(preun):    systemd
114
%else
115
%if 0%{?opensuse_bs} == 0
116
Requires(post):     systemd-units
117
Requires(postun):   systemd-units
118
Requires(preun):    coreutils
119
Requires(preun):    systemd-units
120
%endif
121
%endif
122
%else
123
Requires(post):     chkconfig
124
Requires(post):     initscripts
125
Requires(postun):   initscripts
126
Requires(preun):    chkconfig
127
Requires(preun):    initscripts
128
%endif
129
130
%description
131
Kolab enables you to easily build a groupware server as part of a
132
collaborative environment.
133
134
##
135
## Kolab Telemetry Logging
136
##
137
%package telemetry
138
Summary:            Kolab Telemetry Logging Capabilities
139
Group:              Applications/System
140
Requires:           kolab-cli = %{version}-%{release}
141
142
%description telemetry
143
Cyrus IMAP Telemetry logging handling capabilities for Kolab Groupware
144
145
##
146
## Kolab XML
147
##
148
%package xml
149
Summary:            Kolab XML format wrapper for %{name}
150
Group:              Applications/System
151
Requires:           %{name} = %{version}-%{release}
152
Requires:           python-icalendar
153
Requires:           python-kolab
154
Requires:           python-kolabformat >= 0.5
155
Requires:           python-tzlocal
156
157
%description xml
158
Kolab Format XML bindings wrapper for %{name}
159
160
##
161
## Kolab CLI
162
##
163
%package -n kolab-cli
164
Summary:            Kolab CLI components
165
Group:              Applications/System
166
Requires:           %{name} = %{version}-%{release}
167
Requires:           python-augeas
168
Requires:           python-cheetah
169
Requires:           python-sqlalchemy
170
171
%description -n kolab-cli
172
Kolab CLI utilities
173
174
##
175
## Kolab SASL Authentication Daemon
176
##
177
%package -n kolab-saslauthd
178
Summary:            Kolab SASL Authentication Daemon
179
Group:              Applications/System
180
Requires:           %{name} = %{version}-%{release}
181
Requires:           cyrus-sasl
182
Requires:           cyrus-sasl-plain
183
Requires:           python-sqlalchemy
184
185
%description -n kolab-saslauthd
186
Kolab SASL Authentication Daemon for multi-domain, multi-authn database deployments
187
188
##
189
## Kolab Server implemented in Python
190
##
191
%package -n kolab-server
192
Summary:            Kolab Server implemented in Python
193
Group:              Applications/System
194
Requires:           %{name} = %{version}-%{release}
195
196
%description -n kolab-server
197
Kolab Server implemented in Python
198
199
##
200
## Kolab SMTP Access Policy for Postfix
201
##
202
%package -n postfix-kolab
203
Summary:            Kolab SMTP Access Policy for Postfix
204
Group:              Applications/System
205
%if 0%{?suse_version}
206
BuildRequires:      postfix
207
%endif
208
Requires:           postfix
209
Requires:           %{name} = %{version}-%{release}
210
Requires:           python-sqlalchemy
211
%if 0%{?suse_version}
212
Requires:           python-mysql
213
%else
214
Requires:           MySQL-python
215
%endif
216
217
%description -n postfix-kolab
218
Kolab SMTP Access Policy for Postfix
219
220
##
221
## Wallace
222
##
223
%package -n wallace
224
Summary:            Kolab Content-Filter
225
Group:              Applications/System
226
Requires:           %{name} = %{version}-%{release}
227
Requires:           python-sqlalchemy
228
%if 0%{?suse_version}
229
Requires:           python-mysql
230
%else
231
Requires:           MySQL-python
232
%endif
233
Requires:           python-gnupg
234
Requires:           python-icalendar >= 3.0
235
Requires:           python-tzlocal
236
Requires:           %{name}-xml = %{version}-%{release}
237
238
%description -n wallace
239
This is the Kolab Content Filter, with plugins
240
241
%prep
242
%setup -q
243
244
%if 0%{?kolab_enterprise}
245
%patch0001 -p1
246
%endif
247
248
%build
249
autoreconf -v || automake --add-missing && autoreconf -v
250
%configure
251
252
%install
253
rm -rf %{buildroot}
254
make install DESTDIR=%{buildroot}
255
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
256
cp -pr %SOURCE1 %{buildroot}%{_sysconfdir}/logrotate.d/pykolab
257
258
%if 0%{?with_systemd}
259
mkdir -p %{buildroot}/%{_unitdir}
260
%{__install} -p -m 644 kolabd/kolabd.systemd %{buildroot}/%{_unitdir}/kolabd.service
261
%{__install} -p -m 644 saslauthd/kolab-saslauthd.systemd %{buildroot}/%{_unitdir}/kolab-saslauthd.service
262
%{__install} -p -m 644 wallace/wallace.systemd %{buildroot}/%{_unitdir}/wallace.service
263
mkdir -p %{buildroot}/%{_prefix}/lib/tmpfiles.d/
264
%{__install} -p -m 644 kolabd/kolabd.tmpfiles.d.conf %{buildroot}/%{_prefix}/lib/tmpfiles.d/kolabd.conf
265
%{__install} -p -m 644 wallace/wallace.tmpfiles.d.conf %{buildroot}/%{_prefix}/lib/tmpfiles.d/wallace.conf
266
mkdir -p %{buildroot}/run
267
%{__install} -d -m 755 %{buildroot}/run/kolabd
268
%{__install} -d -m 755 %{buildroot}/run/wallaced
269
%else
270
mkdir -p %{buildroot}/%{_initddir}
271
%{__install} -p -m 755 kolabd/kolabd.sysvinit %{buildroot}/%{_initrddir}/kolabd
272
%{__install} -p -m 755 saslauthd/kolab-saslauthd.sysvinit %{buildroot}/%{_initrddir}/kolab-saslauthd
273
%{__install} -p -m 755 wallace/wallace.sysvinit %{buildroot}/%{_initrddir}/wallace
274
%endif
275
276
%if 0%{?suse_version}
277
mkdir -p %{buildroot}/%{_var}/adm/fillup-templates/
278
%{__install} -p -m 644 kolabd/kolabd.sysconfig %{buildroot}/%{_var}/adm/fillup-templates/sysconfig.kolabd
279
%{__install} -p -m 644 saslauthd/kolab-saslauthd.sysconfig %{buildroot}/%{_var}/adm/fillup-templates/sysconfig.kolab-saslauthd
280
%{__install} -p -m 644 wallace/wallace.sysconfig %{buildroot}/%{_var}/adm/fillup-templates/sysconfig.wallace
281
%else
282
mkdir -p %{buildroot}/%{_sysconfdir}/sysconfig
283
%{__install} -p -m 644 kolabd/kolabd.sysconfig %{buildroot}/%{_sysconfdir}/sysconfig/kolabd
284
%{__install} -p -m 644 saslauthd/kolab-saslauthd.sysconfig %{buildroot}/%{_sysconfdir}/sysconfig/kolab-saslauthd
285
%{__install} -p -m 644 wallace/wallace.sysconfig %{buildroot}/%{_sysconfdir}/sysconfig/wallace
286
%endif
287
288
%find_lang pykolab
289
290
%if 0%{?suse_version}
291
%fdupes %{buildroot}/%{python_sitelib}
292
%endif
293
294
%if 0%{?kolab_enterprise}
295
rm -rf %{buildroot}%{python_sitelib}/pykolab/setup/setup_manticore.py*
296
%endif
297
298
%pre
299
# Add the kolab user and group accounts
300
getent group %{kolab_group} &>/dev/null || groupadd -r %{kolab_group} -g %{kolab_group_id} &>/dev/null
301
getent passwd %{kolab_user} &>/dev/null || \
302
    useradd -r -u %{kolab_user_id} -g %{kolab_group} -d %{_localstatedir}/lib/%{kolab_user} -s /sbin/nologin \
303
        -c "Kolab System Account" %{kolab_user} &>/dev/null || :
304
305
gpasswd -a apache kolab >/dev/null 2>&1 || :
306
307
getent group %{kolabn_group} &>/dev/null || groupadd -r %{kolabn_group} -g %{kolabn_group_id} &>/dev/null
308
getent passwd %{kolabn_user} &>/dev/null || \
309
    useradd -r -u %{kolabn_user_id} -g %{kolabn_group} -d %{_localstatedir}/lib/%{kolabn_user} -s /sbin/nologin \
310
        -c "Kolab System Account (N)" %{kolabn_user} &>/dev/null || :
311
    gpasswd -a %{kolabn_user} %{kolab_group} &>/dev/null || :
312
313
getent group %{kolabr_group} &>/dev/null || groupadd -r %{kolabr_group} -g %{kolabr_group_id} &>/dev/null
314
getent passwd %{kolabr_user} &>/dev/null || \
315
    useradd -r -u %{kolabr_user_id} -g %{kolabr_group} -d %{_localstatedir}/lib/%{kolabr_user} -s /sbin/nologin \
316
        -c "Kolab System Account (R)" %{kolabr_user} &>/dev/null || :
317
318
# Make sure the kolab user and group is added
319
getent passwd %{cyrus_admin} &>/dev/null || \
320
    useradd -r -d %{_localstatedir}/lib/%{cyrus_admin} -s /sbin/nologin \
321
        -c "Kolab Cyrus Administrator Account" %{cyrus_admin} &>/dev/null || :
322
323
# Make sure our user has the correct home directory
324
if [ $1 -gt 1 ] ; then
325
    usermod -d %{_localstatedir}/lib/%{kolab_user} %{kolab_user} &>/dev/null || :
326
    usermod -d %{_localstatedir}/lib/%{kolab_user} %{kolabn_user} &>/dev/null || :
327
    usermod -d %{_localstatedir}/lib/%{kolab_user} %{kolabr_user} &>/dev/null || :
328
fi
329
330
%post -n kolab-saslauthd
331
%if 0%{?suse_version}
332
%fillup_and_insserv -in kolab-saslauthd
333
%endif
334
335
if [ "$1" == "1" ]; then
336
%if 0%{?with_systemd}
337
    /bin/systemctl daemon-reload >/dev/null 2>&1 || :
338
%else
339
    /sbin/chkconfig --add kolab-saslauthd
340
%endif
341
else
342
%if 0%{?with_systemd}
343
    /bin/systemctl condrestart kolab-saslauthd.service >/dev/null 2>&1 || :
344
%else
345
    /sbin/service kolab-saslauthd condrestart
346
%endif
347
fi
348
349
%preun -n kolab-saslauthd
350
if [ "$1" == "0" ]; then
351
%if 0%{?with_systemd}
352
    /bin/systemctl --no-reload disable kolab-saslauthd.service >/dev/null 2>&1 || :
353
    /bin/systemctl stop kolab-saslauthd.service >/dev/null 2>&1 || :
354
%else
355
    /sbin/service kolab-saslauthd stop > /dev/null 2>&1
356
    /sbin/chkconfig --del kolab-saslauthd
357
%endif
358
fi
359
360
%post -n kolab-server
361
%if 0%{?suse_version}
362
%fillup_and_insserv -in kolabd
363
%endif
364
365
if [ "$1" == "1" ] ; then
366
%if 0%{?with_systemd}
367
    /bin/systemctl daemon-reload >/dev/null 2>&1 || :
368
    systemd-tmpfiles --create
369
%else
370
    /sbin/chkconfig --add kolabd
371
%endif
372
fi
373
374
%preun -n kolab-server
375
if [ "$1" == "0" ]; then
376
%if 0%{?with_systemd}
377
    /bin/systemctl --no-reload disable kolabd.service >/dev/null 2>&1 || :
378
    /bin/systemctl stop kolabd.service >/dev/null 2>&1 || :
379
%else
380
    /sbin/service kolabd stop > /dev/null 2>&1
381
    /sbin/chkconfig --del kolabd
382
%endif
383
fi
384
385
%post -n wallace
386
%if 0%{?suse_version}
387
%fillup_and_insserv -in wallace
388
%endif
389
390
if [ "$1" == "1" ] ; then
391
%if 0%{?with_systemd}
392
    /bin/systemctl daemon-reload >/dev/null 2>&1 || :
393
    systemd-tmpfiles --create
394
%else
395
    chkconfig --add wallace
396
%endif
397
else
398
%if 0%{?with_systemd}
399
    /bin/systemctl reload-or-try-restart wallace.service >/dev/null 2>&1 || :
400
%else
401
    /sbin/service wallace condrestart
402
%endif
403
fi
404
405
%preun -n wallace
406
if [ "$1" == "0" ]; then
407
%if 0%{?with_systemd}
408
    /bin/systemctl --no-reload disable wallace.service >/dev/null 2>&1 || :
409
    /bin/systemctl stop wallace.service >/dev/null 2>&1 || :
410
%else
411
    /sbin/service wallace stop > /dev/null 2>&1
412
    /sbin/chkconfig --del wallace
413
%endif
414
fi
415
416
%check
417
nosetests -v tests/unit/ ||:
418
419
%clean
420
rm -rf %{buildroot}
421
422
%files -f pykolab.lang
423
%defattr(-,root,root,-)
424
%doc AUTHORS COPYING README README.tests
425
%doc conf/kolab.conf
426
%attr(0750,kolab-n,kolab) %dir %{_sysconfdir}/kolab
427
%attr(0640,kolab-n,kolab) %config(noreplace) %{_sysconfdir}/kolab/kolab.conf
428
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
429
%dir %{python_sitelib}/pykolab/
430
%exclude %{python_sitelib}/pykolab/telemetry.*
431
%{python_sitelib}/pykolab/*.py
432
%{python_sitelib}/pykolab/*.pyc
433
%{python_sitelib}/pykolab/*.pyo
434
%{python_sitelib}/pykolab/auth/
435
%{python_sitelib}/pykolab/conf/
436
%{python_sitelib}/pykolab/imap/
437
%{python_sitelib}/pykolab/itip/
438
%dir %{python_sitelib}/pykolab/plugins/
439
%{python_sitelib}/pykolab/plugins/*.py
440
%{python_sitelib}/pykolab/plugins/*.pyc
441
%{python_sitelib}/pykolab/plugins/*.pyo
442
%{python_sitelib}/pykolab/plugins/defaultfolders
443
%{python_sitelib}/pykolab/plugins/dynamicquota
444
%{python_sitelib}/pykolab/plugins/recipientpolicy
445
%exclude %{python_sitelib}/pykolab/plugins/sievemgmt
446
%if 0%{?suse_version}
447
%exclude %{python_sitelib}/kolab/
448
%endif
449
%{python_sitelib}/cyruslib.py*
450
%attr(0775,kolab,kolab-n) %dir %{_localstatedir}/lib/kolab/
451
%attr(0775,kolab,kolab-n) %dir %{_localstatedir}/log/kolab/
452
453
%files telemetry
454
%defattr(-,root,root,-)
455
%doc AUTHORS COPYING
456
%{_sbindir}/kolab_parse_telemetry
457
#%{python_sitelib}/pykolab/cli/commandgroups/telemetry.py
458
%{python_sitelib}/pykolab/telemetry.*
459
%{python_sitelib}/pykolab/cli/telemetry/
460
461
%files xml
462
%dir %{python_sitelib}/pykolab/xml
463
%{python_sitelib}/pykolab/xml/*.py
464
%{python_sitelib}/pykolab/xml/*.pyc
465
%{python_sitelib}/pykolab/xml/*.pyo
466
467
%files -n kolab-cli
468
%defattr(-,root,root,-)
469
%{_sbindir}/kolab
470
%{_sbindir}/kolab-conf
471
%{_sbindir}/setup-kolab
472
%dir %{_sysconfdir}/kolab/templates
473
%dir %{_datadir}/kolab
474
%{_datadir}/kolab/templates
475
%dir %{python_sitelib}/pykolab/cli/
476
%{python_sitelib}/pykolab/cli/*.py
477
%{python_sitelib}/pykolab/cli/*.pyc
478
%{python_sitelib}/pykolab/cli/*.pyo
479
%exclude %{python_sitelib}/pykolab/cli/sieve
480
%dir %{python_sitelib}/pykolab/cli/wap
481
%{python_sitelib}/pykolab/cli/wap/*.py
482
%{python_sitelib}/pykolab/cli/wap/*.pyc
483
%{python_sitelib}/pykolab/cli/wap/*.pyo
484
%dir %{python_sitelib}/pykolab/setup/
485
%{python_sitelib}/pykolab/setup/*.py
486
%{python_sitelib}/pykolab/setup/*.pyc
487
%{python_sitelib}/pykolab/setup/*.pyo
488
%dir %{python_sitelib}/pykolab/wap_client/
489
%{python_sitelib}/pykolab/wap_client/*.py
490
%{python_sitelib}/pykolab/wap_client/*.pyc
491
%{python_sitelib}/pykolab/wap_client/*.pyo
492
493
%files -n kolab-saslauthd
494
%defattr(-,root,root,-)
495
%doc AUTHORS COPYING
496
%if 0%{?with_systemd}
497
%{_unitdir}/kolab-saslauthd.service
498
%if 0%{?suse_version}
499
%dir %{_prefix}/lib/systemd/
500
%dir %{_prefix}/lib/systemd/system/
501
%endif
502
%else
503
%{_initrddir}/kolab-saslauthd
504
%endif
505
%if 0%{?suse_version}
506
%config(noreplace) %{_var}/adm/fillup-templates/sysconfig.kolab-saslauthd
507
%else
508
%config(noreplace) %{_sysconfdir}/sysconfig/kolab-saslauthd
509
%endif
510
%{_sbindir}/kolab-saslauthd
511
%{python_sitelib}/saslauthd/
512
%if 0%{?suse_version} > 0 || 0%{?fedora} > 17 || 0%{?rhel} > 6
513
%ghost %dir %{_rundir}/kolab-saslauthd
514
%ghost %dir %{_rundir}/saslauthd
515
%else
516
%dir %{_localstatedir}/run/kolab-saslauthd
517
%dir %{_localstatedir}/run/saslauthd
518
%endif
519
520
%files -n kolab-server
521
%defattr(-,root,root,-)
522
%doc AUTHORS COPYING
523
%if 0%{?with_systemd}
524
%{_unitdir}/kolabd.service
525
%if 0%{?suse_version}
526
%dir %{_prefix}/lib/systemd/
527
%dir %{_prefix}/lib/systemd/system/
528
%dir %{_prefix}/lib/tmpfiles.d/
529
%endif
530
%{_prefix}/lib/tmpfiles.d/kolabd.conf
531
%attr(0700,%{kolab_user},%{kolab_group}) %dir /run/kolabd
532
%else
533
%{_initrddir}/kolabd
534
%endif
535
%if 0%{?suse_version}
536
%config(noreplace) %{_var}/adm/fillup-templates/sysconfig.kolabd
537
%else
538
%config(noreplace) %{_sysconfdir}/sysconfig/kolabd
539
%endif
540
%{_sbindir}/kolabd
541
%{python_sitelib}/kolabd/
542
%if 0%{?suse_version} > 0 || 0%{?fedora} > 17 || 0%{?rhel} > 6
543
%ghost %dir %{_rundir}/kolabd
544
%else
545
%attr(0770,kolab,kolab) %dir %{_localstatedir}/run/kolabd
546
%endif
547
548
%files -n postfix-kolab
549
%defattr(-,root,root,-)
550
%doc AUTHORS COPYING
551
%{_libexecdir}/postfix/kolab_smtp_access_policy
552
553
%files -n wallace
554
%defattr(-,root,root,-)
555
%doc AUTHORS COPYING
556
%if 0%{?with_systemd}
557
%{_unitdir}/wallace.service
558
%if 0%{?suse_version}
559
%dir %{_prefix}/lib/systemd/
560
%dir %{_prefix}/lib/systemd/system/
561
%dir %{_prefix}/lib/tmpfiles.d/
562
%endif
563
%{_prefix}/lib/tmpfiles.d/wallace.conf
564
%if 0%{?suse_version} > 0 || 0%{?fedora} > 17 || 0%{?rhel} > 6
565
%ghost %dir %{_rundir}/wallaced
566
%else
567
%attr(0700,%{kolab_user},%{kolab_group}) %dir /run/wallaced
568
%endif
569
%else
570
%{_initrddir}/wallace
571
%endif
572
%if 0%{?suse_version}
573
%config(noreplace) %{_var}/adm/fillup-templates/sysconfig.wallace
574
%else
575
%config(noreplace) %{_sysconfdir}/sysconfig/wallace
576
%endif
577
%{_sbindir}/wallaced
578
%{python_sitelib}/wallace
579
%attr(0700,%{kolab_user},%{kolab_group}) %dir %{_var}/spool/pykolab
580
%attr(0700,%{kolab_user},%{kolab_group}) %dir %{_var}/spool/pykolab/wallace
581
582
%changelog
583
* Tue Dec 13 2016 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.8.7-1
584
- Release of version 0.8.7
585
586
* Fri Nov 18 2016 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.8.6-1
587
- Release of version 0.8.6
588
589
* Thu Oct 06 2016 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.8.5-1
590
- Release of version 0.8.5
591
592
* Wed Oct 05 2016 Timotheus Pokorra <tp@tbits.net> - 0.8.4-3
593
- Add a patch for T1414: Set LDAP TIMEOUT option only on "immediate" connection
594
595
* Tue Oct 04 2016 Timotheus Pokorra <tp@tbits.net> - 0.8.4-2
596
- Add a patch that fixes setup-kolab again, error in call of subprocess for freshclam
597
598
* Fri Sep 30 2016 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.8.4-1
599
- Release of version 0.8.4
600
601
* Tue Sep 20 2016 Timotheus Pokorra <tp@tbits.net> - 0.8.3-3
602
- Fix for Fedora 23 and higher, python-twisted buildrequires
603
- Create /run directories for kolabd and wallaced services 
604
605
* Wed Jul 27 2016 Dominique Leuenberger (openSUSE) <dimstar@opensuse.org> - 0.8.3-2
606
- Fix build on openSUSE systems: use %_rundir instead of /var/run
607
608
* Fri Jul 22 2016 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.8.3-1
609
- Release of version 0.8.3
610
611
* Wed Mar 09 2016 Timotheus Pokorra <tp@tbits.net> - 0.8.1-2
612
- wallace requires python-gnupg to be installed. avoid ImportError: No module named gnupg
613
614
* Wed Oct 14 2015 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.16-1
615
- New upstream release 0.7.16
616
617
* Mon Jun 08 2015 Christoph Wickert <wickert@kolabsys.com> - 0.7.14-4
618
- Make locale encoding the default system encoding (#5051)
619
- Fix lock check after changed in rP929e67a6
620
- Make 'kolab sync' properly create mailboxes (#3975)
621
622
* Thu May 28 2015 Timotheus Pokorra <tp@tbits.net> - 0.7.14-3
623
- do not require package logrotate
624
625
* Mon May 25 2015 Jochen Hein <jochen@jochen.org> - 0.7.14-2
626
- add logrotate configuration for /var/log/kolab/pykolab.log
627
628
* Thu May 21 2015 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.14-1
629
- Release of version 0.7.14 for continuous integration
630
631
* Thu May 14 2015 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.13-1
632
- Release of version 0.7.13, see;
633
634
  https://issues.kolab.org/buglist.cgi?target_milestone=0.7.13&product=pykolab
635
636
* Wed May 13 2015 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.12-1
637
- Release of version 0.7.12, see;
638
639
  https://issues.kolab.org/buglist.cgi?target_milestone=0.7.12&product=pykolab
640
641
* Tue Mar 31 2015 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.11-2
642
- Back out the changes related to #4459
643
644
* Fri Mar 27 2015 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.11-1
645
- Release of version 0.7.11, see;
646
647
  https://issues.kolab.org/buglist.cgi?target_milestone=0.7.11&product=pykolab
648
649
* Wed Feb 25 2015 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.10-1
650
- Release of version 0.7.10, see;
651
652
  https://issues.kolab.org/buglist.cgi?target_milestone=0.7.10&product=pykolab
653
654
* Mon Feb 23 2015 Daniel Hoffend <dh@dotlan.net> - 0.7.9-3
655
- Default configuration now contains http-auth + trusted local ips
656
657
* Mon Feb 23 2015 Daniel Hoffend <dh@dotlan.net> - 0.7.9-2
658
- set default kolab_freebusy_server to /freebusy
659
660
* Mon Feb 23 2015 Timotheus Pokorra (TBits.net) <tp@tbits.net>
661
- fix for wallace, pid file location, #4673
662
663
* Mon Feb 23 2015 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.9-1
664
- Release of version 0.7.9, see;
665
666
  https://issues.kolab.org/buglist.cgi?target_milestone=0.7.9&product=pykolab
667
668
* Fri Feb 20 2015 Timotheus Pokorra (TBits.net) <tp@tbits.net>
669
- more fixes for CentOS7, fix path for /run/kolabd, fixing #2626
670
- and fixing path for clamd.sock, #3565
671
672
* Thu Feb 19 2015 Timotheus Pokorra (TBits.net) <tp@tbits.net>
673
- fix for CentOS7, fix path for kolab-saslauthd, fixing #4628
674
675
* Wed Feb 18 2015 Daniel Hoffend <dh@dotlan.net> - 0.7.8-3
676
- deliver to shared folders with spaces #4613
677
678
* Sun Feb 15 2015 Daniel Hoffend <dh@dotlan.net> - 0.7.8-2
679
- plugin threading_as_default no longer exists #4570
680
681
* Sat Feb 14 2015 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.8-1
682
- Release of version 0.7.8, see;
683
684
  https://issues.kolab.org/buglist.cgi?target_milestone=0.7.8&product=pykolab
685
686
* Thu Feb 12 2015 Timotheus Pokorra (TBits.net) <tp@tbits.net>
687
- fix for CentOS7, start service mariadb instead of mysqld. fixing #3877
688
- use /run/kolabd for the pid, fixing #2626
689
- fix for CentOS7, only enable dirsrv-admin.service if it actually exists. fixing #4554
690
- use chameleon skin as default. fixing #4557
691
692
* Fri Jan 23 2015 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.7-1
693
- Implement #4256, allowing Wallace messages to be localized
694
695
* Wed Jan 14 2015 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.6-1
696
- Fix LDAP authentication and user searching (#4218)
697
- Enable error logging for Roundcubemail (#4104)
698
- Fix comparison of datetime.datetime and datetime.date (#4079)
699
- Apply invitation policy also to aliases (#4074)
700
701
* Wed Dec 31 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.5-1
702
- New upstream release
703
- Fix default configuration for Roundcube plugin managesieve (#4103)
704
- Fix error due to missing 'domain_name_attribute' variable
705
706
* Thu Dec 11 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.4-5
707
- Fix #4076 domain filter inconsistency.
708
- Fix creating additional user folders
709
710
* Tue Dec  9 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.4-3
711
- Use the correct scheme, hostname and port if so configured
712
- Set the skin to used based on the available skins
713
714
* Mon Dec  8 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.4-1
715
- New upstream release
716
717
* Fri Oct 31 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.3-1
718
- New upstream release
719
720
* Mon Sep 15 2014 Daniel Hoffend <dh@dotlan.net> - 0.7.2-2
721
- added patch to fix setup-kolab mysql.initial
722
- added patch to fix assets_path
723
724
* Thu Sep 11 2014 Jeroen van Meeuwen <vanmeeuwen@kolabsys.com> - 0.7.2-1
725
- Wrap it all up in a new release
726
727
* Tue Aug 26 2014 Aeneas Jaissle <aj@ajaissle.de> - 0.7.1-2
728
- Added patch to use conf.socketfile in kolab-saslauthd
729
730
* Tue Aug 19 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.1-1
731
- New upstream release 0.7.1
732
733
* Thu Aug 14 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.7.0-1
734
- New upstream release 0.7.0
735
736
* Wed Mar  5 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.6.13-1
737
- New upstream release
738
739
* Sun Feb 16 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.6.12-5
740
- Close infinite loop
741
742
* Sat Feb 15 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.6.12-4
743
- New upstream bug-fix release
744
- Do not drop privileges too early
745
- Regenerate auth_cache automatically
746
- Fix typo in Kolab SMTP Access Policy
747
- Fix logger switching gid
748
749
* Tue Jan 28 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.6.11-1
750
- New upstream release
751
752
* Tue Jan 14 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.6.10-1
753
- Fix case-sensitive comparison of server addresses.
754
- Fix initial synchronization of users with mailhost attributes already set.
755
- Add configuration option to prevent kolabd from applying the recipient policy.
756
- Handle errors in subscribing a user to mail folders.
757
758
* Fri Jan 10 2014 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> - 0.6.9-2
759
- Fix 8bit-passwords not passing through log.debug
760
761
* Fri May 17 2013 Jeroen van Meeuwen (Kolab Systems) <vanmeeuwen@kolabsys.com> 0.5.12-2
762
- Initial package of new upstream version
763
764